GearHeads Corner
December 11, 2017, 09:29:24 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Auggie Exception Errors on Startup  (Read 583 times)
0 Members and 1 Guest are viewing this topic.
ds463
Newbie
*
Posts: 7


View Profile
« on: April 10, 2017, 10:41:08 AM »

Like most sticking points, if at first you don't unstick, ask someone else to lick the problem.
The problem: Auggie at startup throws an exasperat ion code 0, the attached dialog may not be readable.
I have Auggie installle d on a Windows 10 machine. Tried compatibi lity mode of all flavors, and
reinstall ed with win32.dll s. Same errors. The first error in the dialog is ntdll file is not available .
Tried running Auggie as administr ator. Tried to turn off the debugger on Visual Studio 2015.
No Luck. Need a point in the right direction . Thanks. Dave


* Error Window2.jpg (44.02 KB, 481x225 - viewed 20 times.)
Logged
BobL
Gearotic Motion
Global Moderator
Hero Member
*****
Posts: 783



View Profile WWW
« Reply #1 on: April 10, 2017, 04:32:21 PM »

Dave;

 Is this an older pc? Can you post your system specifics so we can compare?  I also had issues with Auggie using my older WInXP 32bit, solution for me was to use a 2.5Ghz cpu or better, lots of ram and Win7 or greater. Hope this helps..

Cheers
Bob
Logged

Gearotic Motion
Bob
ds463
Newbie
*
Posts: 7


View Profile
« Reply #2 on: April 10, 2017, 05:55:31 PM »

Nope, my laptop is a Levono Thinkpad, new last December, running Windows 10 Pro.
16 gig ram,  i7 processor, 2.6 gHZ.
I will send more details shortly.
Dave
Logged
ds463
Newbie
*
Posts: 7


View Profile
« Reply #3 on: April 10, 2017, 06:08:57 PM »

Here is the list of error messages in the issued at startup:
A:377842
C:c0000005
base:OnClose 002727D0
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00377842)
 
00377842 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0042AEF4)
 
0042AEF4 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0042AD09)
 
0042AD09 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0042AC55)
 
0042AC55 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00367F00)
 
00367F00 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00367EAB)
 
00367EAB (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0027043A)
 
0027043A (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00310963)
 
00310963 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00311E51)
 
00311E51 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0030D4AE)
 
0030D4AE (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0030DC7C)
 
0030DC7C (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 7749D2B3)
 
7749D2B3 (USER32): (filename not available): SetManipu lationInp utTarget
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 7747E88A)
 
7747E88A (USER32): (filename not available): DispatchM essageW
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 7747E4C0)
 
7747E4C0 (USER32): (filename not available): DispatchM essageW
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 77489910)
 
77489910 (USER32): (filename not available): InSendMes sageEx
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 778308C6)
 
778308C6 (ntdll): (filename not available): KiUserCal lbackDisp atcher
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 77482E99)
 
77482E99 (USER32): (filename not available): CreateWin dowExW
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 77482D38)
 
77482D38 (USER32): (filename not available): CreateWin dowExW
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 6B81A64B)
 
6B81A64B (AcLayers): (filename not available): GetHookAP Is
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0031341F)
 
0031341F (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0030E9DD)
 
0030E9DD (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00360EA1)
 
00360EA1 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00361538)
 
00361538 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00371BA1)
 
00371BA1 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0041AB26)
 
0041AB26 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0035E615)
 
0035E615 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0035E592)
 
0035E592 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0041D3F7)
 
0041D3F7 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 00314A54)
 
00314A54 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 003148A0)
 
003148A0 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0035EB45)
 
0035EB45 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 002619A4)
 
002619A4 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 004970ED)
 
004970ED (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 0046D475)
 
0046D475 (Auggie): (filename not available): cpSweep1D New
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 771F62C4)
 
771F62C4 (KERNEL32): (filename not available): BaseThrea dInitThun k
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 77820FD9)
 
77820FD9 (ntdll): (filename not available): RtlSubscr ibeWnfSta teChangeN otificati on
 
ERROR: SymGetLin eFromAddr 64, GetLastEr ror: 487 (Address: 77820FA4)
 
77820FA4 (ntdll): (filename not available): RtlSubscr ibeWnfSta teChangeN otificati on

Hope this helps.
Dave
 
Logged
ArtF
Administrator
Hero Member
*****
Posts: 4794



View Profile
« Reply #4 on: April 10, 2017, 09:29:12 PM »

Hi Dave:

  Have you tried using a different start profile? Or does it do it with
any profile? Are you trying to start full out Auggie or just the vector
processor module from within Gearotic?

Art
Logged

Thanks, have fun,
Art
ds463
Newbie
*
Posts: 7


View Profile
« Reply #5 on: April 10, 2017, 10:58:53 PM »

  Have you tried using a different start profile? Or does it do it with
any profile?
Not sure what a start profile is, but I have tried to get Windows 10 to resolve compatibi lity issues. I have also tried to start Auggie in Windows 8 and 7 mode. Same error dialog.

Are you trying to start full out Auggie or just the vector
processor module from within Gearotic?
The vector processor module works within Georotic. I am trying to start full out Auggie to work with the PoKeys Controlle r.

Thanks much, Dave
Logged
ArtF
Administrator
Hero Member
*****
Posts: 4794



View Profile
« Reply #6 on: April 11, 2017, 06:51:00 AM »

Dave:

  As the program starts up it asks for a profile name,  does it crash with any profile selected, or if a new
profile is created?

Art
Logged

Thanks, have fun,
Art
ds463
Newbie
*
Posts: 7


View Profile
« Reply #7 on: April 11, 2017, 10:07:22 AM »

My previous attempts included creating a profile, opening an existing profile, and cloning a profile. This morning, I deleted all the profiles created before and named a new one. Same result. Crash with same messages.

I am no computer expert, (in my working days I employed folks to help out), but perhaps there is something to do with access privilege s to the System32 directory . The first error messages look for ntdll, and then Kernel32. For these errors the "file name is not available".  The next errors look to Auggie, also the file name is not available . I am running windows defender for security. Perhaps is defender prohibiti ng calls to System32?

Just a SWAG. (Scientifi c Wild Ass Guess) Oh, the mysteries of Windows.
Dave
Logged
ArtF
Administrator
Hero Member
*****
Posts: 4794



View Profile
« Reply #8 on: April 11, 2017, 12:59:21 PM »

Dave:

 Did it install to C:\Gearotic as the default calls for? Did you run the end section to install the VC support
files?

Art

Logged

Thanks, have fun,
Art
ds463
Newbie
*
Posts: 7


View Profile
« Reply #9 on: April 11, 2017, 10:04:24 PM »

Just to make sure, I uninstall ed Gearotic and Auggie, then ran a fresh reinstall using the default directory (C:/windows/) and 32bit VC redistrib utables.
Same result. Gearotic runs fine, Auggie no.
I was able to get a debug message from windows when I clicked the "X" on the error window instead of "OK"
Attached is a screen shot.

Looking in the installed apps listing I see many VC++ x86 redistibu tables.
VC++ 2008
VC++ 2010
VC++ 2012
VC++ 2013 - 1
VC++ 2013 - 2
VC++ 2017

Is Auggie looking at the wrong file?

Dave



* Debug.png (23.67 KB, 1201x516 - viewed 20 times.)
Logged
ArtF
Administrator
Hero Member
*****
Posts: 4794



View Profile
« Reply #10 on: April 12, 2017, 06:19:20 AM »

Dave:

  Just to help me track it down, does Auggie start if you select Vector processor form the Gearotics tool selection s?

Can you contact me at support@gearotic.com and Ill see if we can figure it out with test versions if necessary to see
what may be causing the issue. The error doesnt help much in that reagrd unless your using as version thats current
to me developme nt version so Ill have to work with you in tandem to figure this one out, I dont have any other reports
of a win10 crash as of yet, but its best to take a look to see why...

Art
Logged

Thanks, have fun,
Art
ArtF
Administrator
Hero Member
*****
Posts: 4794



View Profile
« Reply #11 on: April 12, 2017, 06:43:54 AM »

Dave:

 It was just pointed out to me that you installed in C:\Windows? Thats wrong, dunno why it would do that. Try a reinstall and change the
install folder to C:\Gearotic Thoughts\

  That may be the issue, see i that helps..

Art
Logged

Thanks, have fun,
Art
ds463
Newbie
*
Posts: 7


View Profile
« Reply #12 on: April 12, 2017, 04:10:49 PM »

Just am back to look at your reply. Thanks by the way. Review of my replies show I am in error. The install for Gearotic was placed in C:/Gearotic Motion, not C:/windows.  Per your suggestio n I did another install and placed the files in C:/Gearotic Thoughts. The result is the same - crashes just the same.

Persisten t though I am, I did a search on a portion of all the error messages "SymGetLin eFromAddr 64, GetLastEr ror: 487"
I Googled the error and found the following links of interest:
http://stackoverflow.com/questions/25428001/error-symgetlinefromaddr64-getlasterror-487-address
https://support.microsoft.com/en-us/help/189780/prb-symgetsymfromaddr-fails-with-error-487

I also read into a number of gamer forums that suggest programs that work in Windows 7 and 8 may not run in Windows 10, or intermitt ently fail, if a program is compiled in debug mode without a symbols data base .PDB.
Another SWAG - Auggie is looking for symbols to do debugging, and Windows cannot find them.

Just a guess.

Dave
Logged
ArtF
Administrator
Hero Member
*****
Posts: 4794



View Profile
« Reply #13 on: April 12, 2017, 10:09:40 PM »

Dave:

 Shoulndt matter, runs on my Win10 without a problem. Or did last I checked, Ill try it tomorrow.
The symbols are not found in the error list, if the version is the same as my last compilati on I can track
it down. Contact me at support  @ gearotic. com and Ill send you a version to test where I can trace
the reuslts of the debug list so I know where its crashing. Let me know if you use Skype and Ill set you up so
I can drop you test versions to figure it out with.

Art
Logged

Thanks, have fun,
Art
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!