GearHeads Corner
September 20, 2019, 01:07:01 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
   Home   Help Search Login Register  
Pages: [1]
  Print  
Author Topic: Mach4 Setup  (Read 1096 times)
0 Members and 1 Guest are viewing this topic.
mkanney6
Newbie
*
Posts: 1


View Profile
« on: April 08, 2016, 12:39:33 PM »

I am currently setting up my CNC Router using Mach4.  I have a 3 axis machine with 2 motors controlli ng the x-axis. In Darwin Control and Statistic s screen, in the Ports Control how do i determine what ports to be enabled?  In the Motor Config screen what Port do i use for each axis? My controlle r box came with a paper stating what pin controls each axis direction and step.

Thanks in advance, it will be much appreciat ed.
Logged
ArtF
Administrator
Hero Member
*****
Posts: 5380



View Profile
« Reply #1 on: April 08, 2016, 05:24:07 PM »

Hi:

 In Darwin you use the address of your printer port.  I would imagine you need only one enabled. You would then setup the
four motor outputs as your paper states for the 4 motors. I havent used slaving under Mach4, but I think in the Mach4 config you then config
the x, y, and z to the device "Darwin" and the motor numbers for those axis.

  Darwin doesnt handle the slaving, Theres a setting in Mach4 to set a motor to be a slave of the X axis main motor.

You may want to ask on the Mach4 forum how slaving is handled.. its been awhile since Ive looked at M4's axis config.

Art
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!