GearHeads Corner
May 28, 2020, 07:41:38 PM *
Welcome, Guest. Please login or register.

Login with username, password and session length
 
  Home Help Search Login Register  
  Show Posts
Pages: [1] 2 3 ... 25
1  General Category / Virus Warnings / Re: Virus Warnings on: March 10, 2017, 03:35:59 AM
If they did not and if they could do it but just did not do it and something bad happened they will get their arse handed to them, Me I hope they do it.

2  General Category / Virus Warnings / Re: Virus Warnings on: March 09, 2017, 04:05:33 AM
As the saying goes of course they do, if not them it's someone else, A lot of people forget how WW2 was won.

Over here they say what they do and no one realy cares.
3  General Category / Virus Warnings / Re: Virus Warnings on: March 07, 2017, 03:33:05 AM
Nortons Virus scanner absolutel y kill fusion360, a simple thing like doing a save takes minutes if you're running Norton. And it hates gearotic i had to remove Norton just to install some programs.
I will never get that program again
4  General Category / Auggie: Augmented Machine Controller / Re: the Good the bad and the ugly on: February 02, 2017, 04:59:11 PM
The toolpath being out is in part to haveing the jerk set to 5000000 I changed it to 500000 and it comes back into line, different toolpaths used, I will go back and check the ones that where out.
5  General Category / Auggie: Augmented Machine Controller / Re: the Good the bad and the ugly on: February 01, 2017, 11:56:46 PM
I went back and look at the other codes I sent yesterday the same error repeats stack overflow, adding more files just makes no senses, I will just find what works and stick to that.

the attached file has the error in it it's the same error with all files

6  General Category / Auggie: Augmented Machine Controller / Re: the Good the bad and the ugly on: February 01, 2017, 05:29:03 PM
Art I have worked out what it is it's how it enters the cut with a smooth, or smooth helix, helix and profile it fails. the cutting it self is fine it EStop on a entering of the cut ever at the start or during the cut.
If i have the same toolpath but have it set to plunge it's fine.

feed optimizat ion does not have an effect on the cut EStoping

lead in and outs are fine.

Whats in the attached file is all 3D or 2D pockets a normal op, I will do adaptive clearing tomorrow I will go through all cut ops and they will be named properly so i can track them all.

since's I am so crap at coding I need to do something to help make Auggie better.
once I have done them all in fusion I will do V carve pro cut types what I would say will be fine it's what you use.



 
7  General Category / Auggie: Augmented Machine Controller / Re: the Good the bad and the ugly on: January 31, 2017, 07:52:27 PM
All other toolpath I have tried so far have been fine, Auggie does not like doing a helix in 3D 2D is ok, it's the entry into the cut where it fail between line 20 and 34.

I have a lot to do to the post from fusion removing G42 and a couple of other changes, I was going to leave G54 there.
8  General Category / Auggie: Augmented Machine Controller / the Good the bad and the ugly on: January 31, 2017, 04:45:03 PM
Hay Art been playing some more.
I have found haveing the toolpath set some certain ways Auggie Estops and it spits out that it's a stack over flow what stops it.

Also some G codes go off the path they start on the path then drift off by a small amount then it goes back onto the path before the G code is finished.

and some Gcodes are fine.

Max jerk limit 5000000
constant vel
max vc radius .5
look ahead 10

files are attached the file marked fail are the one's that had the EStop, loss are the ones that lose the path then go back to it. good are just that good
9  General Category / Virus Warnings / Re: Virus Warnings on: January 04, 2017, 04:27:16 PM
The more popular a virus scanner is, it increases the chances of being hit, more hacker trying to get through.

The less known it is the safer it is, you just have to make sure your password's have nothing in common with you as in if you like dragons don't have dragon in your password Have goat instead.
10  General Category / Auggie: Augmented Machine Controller / Re: Script Bug on: January 02, 2017, 06:09:37 PM
Being able to add a bit of code here and there without haveing to go to great lengths writing code, It makes Auggie quite easy to use.

The only thing left now is tool hight, that can weight to i learn a lot more.

I wont to do a screen set for a filament winder, I know I don't need to I can just use the Arduino code I have now but why not.
11  General Category / Auggie: Augmented Machine Controller / Re: Script Bug on: January 02, 2017, 04:46:25 PM
Found another one I added a bit of code into the spindle on and spindle off, I could not get it to work at all yesterday I new it should work, but it just would not work, did all the normal stuff restart Auggie the computer all that, nothing worked.
It just led.setst atemask (1) in spindle on and led.setst atemask (0) in spindle off with the call to the led above it as well.

turned Auggie on this morning and it working cool test it, it did not work then it did.

What I found is if the the buffer and the screen prints are up to date it will work, as in nothing new running all print in the toolpath window up to date it will work as it should.

If there are prints still scrolling in the toolpath window it wont work to it is uptodate.

It may not be Auggie being slow, The computer I am useing I think is about to die so it could be the computer. triple check before posting I can reproduce it every time.
12  General Category / Auggie: Augmented Machine Controller / Re: Script Bug on: January 02, 2017, 04:07:18 PM
yep 13 seconds I increased it so i could time it easier and it's on.

Straight out pasting of this just failed every time I did it.

led = Led("Main_LED_ 0");
led.SetSt ateMask(1);
sleep(13);
led.SetSt ateMask(0);

Setting a number to the led and changing just the number in the code it would fail until I use shift right click for the dro address, if I coped and pasted it again it would fail.

I tried it a few time trying to work out what part of the code was failing, Mach4 was doing the same thing.
13  General Category / Auggie: Augmented Machine Controller / Script Bug on: December 31, 2016, 01:11:18 AM
Hi I am playing with a LED on screen.

If i copy and past this

led = Led("Main_LED_ 0");
led.SetSt ateMask(1);
sleep(13);
led.SetSt ateMask(0);  //this makes the LED turn off, then on again in 3 seconds.

The LED will not work at all.

If delete this ("Main_LED_ 0"); and use shift right click to places the LED name it will work.

I think the copy and past may be a part of the problems I am Having and why some things will work where I typed them in then wont work where I pasted them, the script is running when this happens just not showing anything on screen.
14  General Category / Auggie: Augmented Machine Controller / Re: print where on: December 30, 2016, 06:35:02 PM
I change everythin g back to SpindleSp eed, It sort of worked but I have corrupted auggie again, (I have to do a delete all and a reinstall again I am getting good at killing Auggie)
It shows up in the scripter that it is working you see the change but it's out by 0000 it could well be the corruptio n that's doing it if i type in 10000 it shows as 1 not 10000.
It was correct when I was just useing a DRO on screen.

I will have a crank soon
15  General Category / Auggie: Augmented Machine Controller / Re: print where on: December 30, 2016, 12:28:30 AM
I am useing the spindle Relay library, Its what you told me to use, with the superpid controlli ng the spindle it's pwm.

I Have this on a DRO on screen and it works (turns out watching your vids help)

global SpindleSp eed = function( speed )
   {
    mydro=DRO("Main_DRO_ 20");
    mydro.Set Value(speed);

    myval = mydro.Get Value();
    print(myval);
    GlobalSet("Main_DRO_ 20",speed );
};

It's just so I can see what the G code spindle speed is so I can compare it too what the superpid shows, it's out by a few 00 RPM. I have it print as well

I changed the feed override panel to a spindle override panel, I used SpindleSp eed as the ver. in both dro's and the slider and it works sort off with the latest version, the last version it would not work at all.
This is where the problems came in I thought it was me doing something wrong, it sort of is.
Pages: [1] 2 3 ... 25
Powered by MySQL Powered by PHP Powered by SMF 1.1.11 | SMF © 2006-2009, Simple Machines LLC Valid XHTML 1.0! Valid CSS!